# CVE-2024-10081: codechecker vulnerable to authentication bypass when using specifically crafted URLs

> An authentication bypass in CodeChecker allows attackers to gain superuser access and modify products via API endpoints ending in Authentication.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2024
- **Updated:** 6 Nov 2024
- **Also known as:** GHSA-f3f8-vx3w-hp5q, PYSEC-2024-238

## What is CVE-2024-10081?

CVE-2024-10081 is a critical authentication bypass vulnerability in Ericsson CodeChecker, published on 6 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeChecker is an analyzer tooling, defect database and viewer extension for the Clang Static Analyzer and Clang Tidy. 
Authentication bypass occurs when the API URL ends with Authentication. This bypass allows superuser access to all API endpoints other than Authentication. These endpoints include the ability to add, edit, and remove products, among others. All endpoints, apart from the /Authentication is affected by the vulnerability.

This issue affects CodeChecker: through 6.24.1.

Weakness: CWE-420 (Unprotected Alternate Channel), CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2024-10081?

3 open source packages ship an affected version, including codechecker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codechecker` | PyPI | All versions | 6.24.2 |
| `codechecker` | PyPI | All versions | 6.24.2 |
| `codechecker` | PyPI | All versions | 6.24.2 |

Products: Ericsson Codechecker.

## How do I fix CVE-2024-10081?

Upgrade codechecker to 6.24.2 or later.

## Is CVE-2024-10081 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-10081 exists.

Public exploit code:

- CodeChecker <= 6.24.1 - Authentication Bypass (nuclei): http/cves/2024/CVE-2024-10081.yaml

## Other vulnerabilities in Ericsson CodeChecker

- [CVE-2026-25660](https://insights.sbomify.com/CVE-2026-25660/): Authentication bypass for certain API calls (critical 9.3)
- [CVE-2024-10082](https://insights.sbomify.com/CVE-2024-10082/): codechecker authentication method confusion vulnerability allows logging in as the built-in root user from an external service (high 8.7)
- [CVE-2024-53829](https://insights.sbomify.com/CVE-2024-53829/): Cross-Site Request Forgery in CodeChecker API (high 8.2)
- [CVE-2023-49793](https://insights.sbomify.com/CVE-2023-49793/): Path traversal in `CodeChecker server` in the endpoint of `CodeChecker store` (medium 6.5)
- [CVE-2025-1300](https://insights.sbomify.com/CVE-2025-1300/): Open redirect in CodeChecker web server (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-10081 and fix it if it is affected.

What it is: CVE-2024-10081 is a critical authentication bypass vulnerability in Ericsson CodeChecker, published on 6 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-10081 exists.

Affected packages and fixed versions:
- codechecker (PyPI): affected all versions; fixed in 6.24.2
- codechecker (PyPI): affected all versions; fixed in 6.24.2
- codechecker (PyPI): affected all versions; fixed in 6.24.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-10081/ (Markdown: https://insights.sbomify.com/CVE-2024-10081/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-10081
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-10081
- OSV: https://osv.dev/vulnerability/CVE-2024-10081

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-10081/
Summaries are generated and may contain mistakes; the official description above is the record.
