{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-10124 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-10124 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-10124 is a critical missing authorization vulnerability in themehunk Vayu Blocks – Website Builder for the Block Editor, published on 12 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-10124 and fix it if it is affected.\n\nWhat it is: CVE-2024-10124 is a critical missing authorization vulnerability in themehunk Vayu Blocks – Website Builder for the Block Editor, published on 12 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-10124 in the wild and no public exploit code.\n\nAffected product: themehunk Vayu Blocks – Website Builder for the Block Editor. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-10124/ (Markdown: https://insights.sbomify.com/CVE-2024-10124/index.md)","id":"CVE-2024-10124","markdown":"https://insights.sbomify.com/CVE-2024-10124/index.md","name":"CVE-2024-10124","record":{"aliases":["GHSA-pw34-xq7x-mmwc"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can install and activate arbitrary plugins due to missing capability checks, potentially leading to remote code execution.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"The Vayu Blocks – Gutenberg Blocks for WordPress \u0026 WooCommerce plugin for WordPress is vulnerable to unauthorized arbitrary plugin installation and activation due to a missing capability check on the tp_install() function in all versions up to, and including, 1.1.1. This makes it possible for unauthenticated attackers to install and activate arbitrary plugins which can be leveraged to achieve remote code execution if another vulnerable plugin is installed and activated. This vulnerability was partially patched in version 1.1.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2024-12-12","github_poc":2,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-01-05T20:42:10Z","kind":"github_poc","ref":"https://github.com/Nxploited/CVE-2024-10124-Poc","stars":1,"title":null},{"date":"2024-12-12T15:13:30Z","kind":"github_poc","ref":"https://github.com/RandomRobbieBF/CVE-2024-10124","stars":0,"title":"Vayu Blocks – Gutenberg Blocks for WordPress \u0026 WooCommerce \u003c= 1.1.1 - Missing Authorization to Unauthenticated Arbitrary Plugin Installation/Activation"}],"tier":"poc_unverified"},"has_fix":null,"headline":"Missing authorization in Vayu Blocks – Website Builder for the Block Editor","id":"CVE-2024-10124","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":0,"n_references":6,"next":{"headline":"Lack of JWT issuer and signer validation","id":"CVE-2024-10125"},"packages":[],"prev":{"headline":"Tenda AC8 saveParentControlInfo compare_parentcontrol_time stack-based overflow","id":"CVE-2024-10123"},"products":["Vayu Blocks – Website Builder for the Block Editor"],"published":"2024-12-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["themehunk"]},"summary":"Unauthenticated attackers can install and activate arbitrary plugins due to missing capability checks, potentially leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2024-10124/"}