# CVE-2024-10174: Auth bypass in Project Manager – AI Powered Project Management, Task Management, Kanban Board & Time Tracker

> Unauthenticated attackers can bypass authorization to access administrative REST routes and modify data in the WP Project Manager plugin.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Nov 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-cmvg-6592-4mfp

## What is CVE-2024-10174?

CVE-2024-10174 is a high-severity authentication bypass vulnerability in wedevs Project Manager – AI Powered Project Management, Task Management, Kanban Board & Time Tracker, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The WP Project Manager – Task, team, and project management plugin featuring kanban board and gantt charts plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 2.6.13 via the 'Abstract_Permission' class due to missing validation on the 'user_id' user controlled key. This makes it possible for unauthenticated attackers to spoof their identity to that of an administrator and access all of the plugins REST routes.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2024-10174?

It affects 1 product.


Products: Wedevs Wp Project Manager.

## How do I fix CVE-2024-10174?

No fix has been published for CVE-2024-10174 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-10174 being exploited?

There is no known exploitation of CVE-2024-10174 in the wild and no public exploit code.

## Other vulnerabilities in wedevs Project Manager – AI Powered Project Management, Task Management, Kanban Board & Time Tracker

- [CVE-2023-3636](https://insights.sbomify.com/CVE-2023-3636/): WP Project Manager <= 2.6.4 - Arbitrary Usermeta Update to Authenticated (Subscriber+) Privilege Escalation (high 8.8)
- [CVE-2023-34383](https://insights.sbomify.com/CVE-2023-34383/): WordPress WP Project Manager Plugin <= 2.6.0 is vulnerable to SQL Injection (high 8.5)
- [CVE-2024-13500](https://insights.sbomify.com/CVE-2024-13500/): WP Project Manager <= 2.6.17 - Authenticated (Subscriber+) SQL Injection via orderby Parameter (medium 6.5)
- [CVE-2024-13752](https://insights.sbomify.com/CVE-2024-13752/): WP Project Manager <= 2.6.17 - Missing Authorization to Authenticated (Subscriber+) Limited Arbitrary Options Update (medium 6.5)
- [CVE-2024-12195](https://insights.sbomify.com/CVE-2024-12195/): SQL injection in Project Manager – AI Powered Project Management, Task Management, Kanban Board & Time Tracker (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-10174 and fix it if it is affected.

What it is: CVE-2024-10174 is a high-severity authentication bypass vulnerability in wedevs Project Manager – AI Powered Project Management, Task Management, Kanban Board & Time Tracker, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-10174 in the wild and no public exploit code.

Affected product: wedevs Project Manager – AI Powered Project Management, Task Management, Kanban Board & Time Tracker. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-10174/ (Markdown: https://insights.sbomify.com/CVE-2024-10174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-10174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-10174
- OSV: https://osv.dev/vulnerability/CVE-2024-10174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-10174/
Summaries are generated and may contain mistakes; the official description above is the record.
