{"answers":{"affected":"3 open source packages ship an affected version, including litellm.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-10188 exists.","fix":"Upgrade litellm to 1.53.1.dev1 or later.","what":"CVE-2024-10188 is a high-severity denial of service vulnerability in berriai/litellm, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-10188 and fix it if it is affected.\n\nWhat it is: CVE-2024-10188 is a high-severity denial of service vulnerability in berriai/litellm, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-10188 exists.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected all versions; fixed in 1.53.1.dev1\n- litellm (PyPI): affected all versions; fixed in 1.53.1.dev1\n- litellm (PyPI): affected all versions; fixed in 1.53.1.dev1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-10188/ (Markdown: https://insights.sbomify.com/CVE-2024-10188/index.md)","id":"CVE-2024-10188","markdown":"https://insights.sbomify.com/CVE-2024-10188/index.md","name":"CVE-2024-10188","record":{"aliases":["GHSA-gw2q-qw9j-rgv7","PYSEC-2026-1549"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python LLM proxy library","requires_auth":"none","summary":"Unauthenticated attackers can crash the litellm server by sending malicious input parsed by ast.literal_eval, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"A vulnerability in BerriAI/litellm, as of commit 26c03c9, allows unauthenticated users to cause a Denial of Service (DoS) by exploiting the use of ast.literal_eval to parse user input. This function is not safe and is prone to DoS attacks, which can crash the litellm Python server.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of Service in BerriAI/litellm","id":"CVE-2024-10188","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-site scripting in Anchor Episodes Index (Spotify for Podcasters)","id":"CVE-2024-10189"},"packages":[{"ecosystem":"PyPI","fixed":["1.53.1.dev1"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-gw2q-qw9j-rgv7"},{"ecosystem":"PyPI","fixed":["1.53.1.dev1"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-gw2q-qw9j-rgv7"},{"ecosystem":"PyPI","fixed":["1.53.1.dev1"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"PYSEC-2026-1549"}],"prev":{"headline":"myCred \u003c= 2.7.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via mycred_link Shortcode","id":"CVE-2024-10187"},"products":["berriai/litellm"],"published":"2025-03-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-20","vendors":["berriai"]},"summary":"Unauthenticated attackers can crash the litellm server by sending malicious input parsed by ast.literal_eval, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2024-10188/"}