# CVE-2024-10188: Denial of Service in BerriAI/litellm

> Unauthenticated attackers can crash the litellm server by sending malicious input parsed by ast.literal_eval, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-gw2q-qw9j-rgv7, PYSEC-2026-1549

## What is CVE-2024-10188?

CVE-2024-10188 is a high-severity denial of service vulnerability in berriai/litellm, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in BerriAI/litellm, as of commit 26c03c9, allows unauthenticated users to cause a Denial of Service (DoS) by exploiting the use of ast.literal_eval to parse user input. This function is not safe and is prone to DoS attacks, which can crash the litellm Python server.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-10188?

3 open source packages ship an affected version, including litellm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.53.1.dev1 |
| `litellm` | PyPI | All versions | 1.53.1.dev1 |
| `litellm` | PyPI | All versions | 1.53.1.dev1 |

## How do I fix CVE-2024-10188?

Upgrade litellm to 1.53.1.dev1 or later.

## Is CVE-2024-10188 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-10188 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-10188 and fix it if it is affected.

What it is: CVE-2024-10188 is a high-severity denial of service vulnerability in berriai/litellm, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-10188 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.53.1.dev1
- litellm (PyPI): affected all versions; fixed in 1.53.1.dev1
- litellm (PyPI): affected all versions; fixed in 1.53.1.dev1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-10188/ (Markdown: https://insights.sbomify.com/CVE-2024-10188/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-10188
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-10188
- OSV: https://osv.dev/vulnerability/CVE-2024-10188

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-10188/
Summaries are generated and may contain mistakes; the official description above is the record.
