CVE-2024-1019 WAF bypass of the ModSecurity v3 release line

High 8.6 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-1019?

CVE-2024-1019 is a high-severity vulnerability in OWASP ModSecurity ModSecurity, published on 30 Jan 2024.

Official description

ModSecurity / libModSecurity 3.0.0 to 3.0.11 is affected by a WAF bypass for path-based payloads submitted via specially crafted request URLs. ModSecurity v3 decodes percent-encoded characters present in request URLs before it separates the URL path component from the optional query string component. This results in an impedance mismatch versus RFC compliant back-end applications. The vulnerability hides an attack payload in the path component of the URL from WAF rules inspecting it. A back-end may be vulnerable if it uses the path component of request URLs to construct queries. Integrators and users are advised to upgrade to 3.0.12. The ModSecurity v2 release line is not affected by this vulnerability.

Weakness: CWE-20

Which versions are affected by CVE-2024-1019?

2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 1 product.

PackageAffectedFixed in
modsecurity BitnamiFrom 3.0.03.0.12
modsecurity2 BitnamiFrom 3.0.0None

Products include Owasp Modsecurity.

How do I fix CVE-2024-1019?

Upgrade modsecurity to 3.0.12 or later.

Is CVE-2024-1019 being exploited?

There is no known exploitation of CVE-2024-1019 in the wild and no public exploit code.

Sources

Also known as BIT-modsecurity-2024-1019, BIT-modsecurity2-2024-1019, DEBIAN-CVE-2024-1019, GHSA-w56r-g989-xqw3, UBUNTU-CVE-2024-1019, openSUSE-SU-2024:13732-1.

Is CVE-2024-1019 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free