{"answers":{"affected":"2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-1019 in the wild and no public exploit code.","fix":"Upgrade modsecurity to 3.0.12 or later.","what":"CVE-2024-1019 is a high-severity vulnerability in OWASP ModSecurity ModSecurity, published on 30 Jan 2024."},"fix_prompt":"Check this codebase for CVE-2024-1019 and fix it if it is affected.\n\nWhat it is: CVE-2024-1019 is a high-severity vulnerability in OWASP ModSecurity ModSecurity, published on 30 Jan 2024. \nExploitation: There is no known exploitation of CVE-2024-1019 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- modsecurity (Bitnami): affected from 3.0.0; fixed in 3.0.12\n- modsecurity2 (Bitnami): affected from 3.0.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-1019/ (Markdown: https://insights.sbomify.com/CVE-2024-1019/index.md)","id":"CVE-2024-1019","markdown":"https://insights.sbomify.com/CVE-2024-1019/index.md","name":"CVE-2024-1019","record":{"aliases":["BIT-modsecurity-2024-1019","BIT-modsecurity2-2024-1019","DEBIAN-CVE-2024-1019","GHSA-w56r-g989-xqw3","UBUNTU-CVE-2024-1019","openSUSE-SU-2024:13732-1"],"analysis":null,"analysis_generated_by":null,"assigner":"NCSC.ch","cpe":[{"product":"modsecurity","vendor":"owasp"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"ModSecurity / libModSecurity 3.0.0 to 3.0.11 is affected by a WAF bypass for path-based payloads submitted via specially crafted request URLs. ModSecurity v3 decodes percent-encoded characters present in request URLs before it separates the URL path component from the optional query string component. This results in an impedance mismatch versus RFC compliant back-end applications. The vulnerability hides an attack payload in the path component of the URL from WAF rules inspecting it. A back-end may be vulnerable if it uses the path component of request URLs to construct queries. Integrators and users are advised to upgrade to 3.0.12. The ModSecurity v2 release line is not affected by this vulnerability.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WAF bypass of the ModSecurity v3 release line","id":"CVE-2024-1019","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":null,"year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Rebuild proxy-download getStorageFile cross site scripting","id":"CVE-2024-1020"},"packages":[{"ecosystem":"Bitnami","fixed":["3.0.12"],"introduced":["3.0.0"],"last_affected":[],"package":"modsecurity","purl":"pkg:bitnami/modsecurity","source":"BIT-modsecurity-2024-1019"},{"ecosystem":"Bitnami","fixed":[],"introduced":["3.0.0"],"last_affected":[],"package":"modsecurity2","purl":"pkg:bitnami/modsecurity2","source":"BIT-modsecurity2-2024-1019"}],"prev":{"headline":"PbootCMS cross site scripting","id":"CVE-2024-1018"},"products":["ModSecurity"],"published":"2024-01-30","related":[{"cvss_score":8.6,"headline":"Security feature bypass in ModSecurity","id":"CVE-2026-52747","kev_date_added":null,"published":"2026-07-10"},{"cvss_score":8.2,"headline":"ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators","id":"CVE-2026-42268","kev_date_added":null,"published":"2026-05-12"},{"cvss_score":8.2,"headline":"libModSecurity3 denial of service via segfault when using t:hexDecode on single-character query strings","id":"CVE-2026-30923","kev_date_added":null,"published":"2026-05-05"},{"cvss_score":7.5,"headline":"ModSecurity has possible DoS vulnerability in sanitiseArg action","id":"CVE-2025-48866","kev_date_added":null,"published":"2025-06-02"},{"cvss_score":7.5,"headline":"Trustwave ModSecurity 3.x before 3.0.10 has Inefficient Algorithmic Complexity.","id":"CVE-2023-38285","kev_date_added":null,"published":"2023-07-26"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2023-28882","kev_date_added":null,"published":"2023-04-28"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-17","vendors":["OWASP ModSecurity"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-1019/"}