# CVE-2024-1019: WAF bypass of the ModSecurity v3 release line


- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 30 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** BIT-modsecurity-2024-1019, BIT-modsecurity2-2024-1019, DEBIAN-CVE-2024-1019, GHSA-w56r-g989-xqw3, UBUNTU-CVE-2024-1019, openSUSE-SU-2024:13732-1

## What is CVE-2024-1019?

CVE-2024-1019 is a high-severity vulnerability in OWASP ModSecurity ModSecurity, published on 30 Jan 2024. 

### Official description

ModSecurity / libModSecurity 3.0.0 to 3.0.11 is affected by a WAF bypass for path-based payloads submitted via specially crafted request URLs. ModSecurity v3 decodes percent-encoded characters present in request URLs before it separates the URL path component from the optional query string component. This results in an impedance mismatch versus RFC compliant back-end applications. The vulnerability hides an attack payload in the path component of the URL from WAF rules inspecting it. A back-end may be vulnerable if it uses the path component of request URLs to construct queries. Integrators and users are advised to upgrade to 3.0.12. The ModSecurity v2 release line is not affected by this vulnerability.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-1019?

2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modsecurity` | Bitnami | From 3.0.0 | 3.0.12 |
| `modsecurity2` | Bitnami | From 3.0.0 | None |

Products: Owasp Modsecurity.

## How do I fix CVE-2024-1019?

Upgrade modsecurity to 3.0.12 or later.

## Is CVE-2024-1019 being exploited?

There is no known exploitation of CVE-2024-1019 in the wild and no public exploit code.

## Other vulnerabilities in OWASP ModSecurity ModSecurity

- [CVE-2026-52747](https://insights.sbomify.com/CVE-2026-52747/): Security feature bypass in ModSecurity (high 8.6)
- [CVE-2026-42268](https://insights.sbomify.com/CVE-2026-42268/): ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators (high 8.2)
- [CVE-2026-30923](https://insights.sbomify.com/CVE-2026-30923/): libModSecurity3 denial of service via segfault when using t:hexDecode on single-character query strings (high 8.2)
- [CVE-2025-48866](https://insights.sbomify.com/CVE-2025-48866/): ModSecurity has possible DoS vulnerability in sanitiseArg action (high 7.5)
- [CVE-2023-38285](https://insights.sbomify.com/CVE-2023-38285/): Trustwave ModSecurity 3.x before 3.0.10 has Inefficient Algorithmic Complexity. (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1019 and fix it if it is affected.

What it is: CVE-2024-1019 is a high-severity vulnerability in OWASP ModSecurity ModSecurity, published on 30 Jan 2024. 
Exploitation: There is no known exploitation of CVE-2024-1019 in the wild and no public exploit code.

Affected packages and fixed versions:
- modsecurity (Bitnami): affected from 3.0.0; fixed in 3.0.12
- modsecurity2 (Bitnami): affected from 3.0.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1019/ (Markdown: https://insights.sbomify.com/CVE-2024-1019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1019
- OSV: https://osv.dev/vulnerability/CVE-2024-1019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1019/
Summaries are generated and may contain mistakes; the official description above is the record.
