# CVE-2024-10214: Incorrect Session Creation with Desktop SSO

> Incorrect session creation in Mattermost desktop SSO allows attackers to bypass authentication controls when specific settings are enabled.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Oct 2024
- **Updated:** 28 Oct 2024
- **Also known as:** GHSA-hm57-h27x-599c, GO-2024-3227

## What is CVE-2024-10214?

CVE-2024-10214 is a low-severity authentication bypass vulnerability in Mattermost Mattermost, published on 28 Oct 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mattermost versions 9.11.X <= 9.11.1, 9.5.x <= 9.5.9 icorrectly issues two sessions when using desktop SSO - one in the browser and one in desktop with incorrect settings.

Weakness: CWE-303 (Incorrect Implementation of Authentication Algorithm)

## Which versions are affected by CVE-2024-10214?

6 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20240821220019-0d6b1070a26f |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20240821220019-0d6b1070a26f |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20240821220019-0d6b1070a26f |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost.

## How do I fix CVE-2024-10214?

Upgrade github.com/mattermost/mattermost/server/v8 to 8.0.0-20240821220019-0d6b1070a26f or later.

## Is CVE-2024-10214 being exploited?

There is no known exploitation of CVE-2024-10214 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost

- [CVE-2019-20851](https://insights.sbomify.com/CVE-2019-20851/): Path traversal in n/a (critical 9.1)
- [CVE-2024-39274](https://insights.sbomify.com/CVE-2024-39274/): Malicious remote can add users to arbitrary teams and channels (high 8.7)
- [CVE-2024-39777](https://insights.sbomify.com/CVE-2024-39777/): Malicious remote can invite itself to an arbitrary local channel (high 8.7)
- [CVE-2024-39830](https://insights.sbomify.com/CVE-2024-39830/): Timing attack during remote cluster token comparison when shared channels are enabled (high 8.1)
- [CVE-2023-3615](https://insights.sbomify.com/CVE-2023-3615/): Lack of server certificate validation in websockets connection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-10214 and fix it if it is affected.

What it is: CVE-2024-10214 is a low-severity authentication bypass vulnerability in Mattermost Mattermost, published on 28 Oct 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-10214 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20240821220019-0d6b1070a26f
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20240821220019-0d6b1070a26f
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20240821220019-0d6b1070a26f
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-10214/ (Markdown: https://insights.sbomify.com/CVE-2024-10214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-10214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-10214
- OSV: https://osv.dev/vulnerability/CVE-2024-10214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-10214/
Summaries are generated and may contain mistakes; the official description above is the record.
