CVE-2024-10240 Exposure of Sensitive System Information to an Unauthorized Control Sphere in GitLab
Unauthenticated attackers can read sensitive merge request information from private projects in GitLab EE, requiring an upgrade to secure data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-10240?
CVE-2024-10240 is a medium-severity vulnerability in Gitlab Gitlab, published on 26 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue has been discovered in GitLab EE affecting all versions starting from 17.3 before 17.3.7, all versions starting from 17.4 before 17.4.4, all versions starting from 17.5 before 17.5.2 in which an unauthenticated user may be able to read some information about an MR in a private project, under certain circumstances.
Weakness: CWE-497
Which versions are affected by CVE-2024-10240?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 17.3.0 | 17.3.7, 17.4.4, 17.5.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-10240?
Upgrade gitlab to a fixed version for your release line: 17.3.7, 17.4.4 or 17.5.2.
Is CVE-2024-10240 being exploited?
There is no known exploitation of CVE-2024-10240 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-10240, GHSA-f82f-w24c-j3ww, UBUNTU-CVE-2024-10240.