CVE-2024-10383 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab VSCode Fork

High 8.7 Published Updated

Attackers can execute arbitrary scripts in the GitLab Web IDE by tricking users into opening malicious Jupyter notebook files.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-10383?

CVE-2024-10383 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 7 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in the gitlab-web-ide-vscode-fork component distributed over CDN affecting all versions prior to 1.89.1-1.0.0-dev-20241118094343and used by all versions of GitLab CE/EE starting from 15.11 prior to 17.3 and which also temporarily affected versions 17.4, 17.5 and 17.6, where a XSS attack was possible when loading .ipynb files in the web IDE

Weakness: CWE-79

Which versions are affected by CVE-2024-10383?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.11.017.3.0

Products include Gitlab Gitlab.

How do I fix CVE-2024-10383?

Upgrade gitlab to 17.3.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-10383 being exploited?

There is no known exploitation of CVE-2024-10383 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-10383, GHSA-v575-96v9-gxhw, UBUNTU-CVE-2024-10383.

Is CVE-2024-10383 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free