# CVE-2024-10530: Kognetiks Chatbot for WordPress <= 2.1.7 - Missing Authorization to Authenticated (Subscriber+) Assistant Addition

> Authenticated subscribers can create new GTP assistants due to missing capability checks in the Kognetiks Chatbot plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Nov 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-jfcv-w56x-mqqx

## What is CVE-2024-10530?

CVE-2024-10530 is a medium-severity missing authorization vulnerability in Kognetiks Chatbot for WordPress, published on 13 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Kognetiks Chatbot for WordPress plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the add_new_assistant() function in all versions up to, and including, 2.1.7. This makes it possible for authenticated attackers, with subscriber-level access and above, to create new GTP assistants.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-10530?

It affects 1 product.


Products: Kognetiks Kognetiks Chatbot.

## How do I fix CVE-2024-10530?

No fix has been published for CVE-2024-10530 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-10530 being exploited?

There is no known exploitation of CVE-2024-10530 in the wild and no public exploit code.

## Other vulnerabilities in Kognetiks Chatbot for WordPress

- [CVE-2024-10684](https://insights.sbomify.com/CVE-2024-10684/): Kognetiks Chatbot for WordPress <= 2.1.7 - Reflected Cross-Site Scripting (medium 6.1)
- [CVE-2024-10529](https://insights.sbomify.com/CVE-2024-10529/): Kognetiks Chatbot for WordPress <= 2.1.7 - Missing Authorization to Authenticated (Subscriber+) Assistant Deletion (medium 5.3)
- [CVE-2024-10531](https://insights.sbomify.com/CVE-2024-10531/): Kognetiks Chatbot for WordPress <= 2.1.7 - Missing Authorization to Authenticated (Subscriber+) Assistant Update (medium 5.3)
- [CVE-2024-11143](https://insights.sbomify.com/CVE-2024-11143/): Cross-site request forgery in Kognetiks Chatbot for WordPress (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-10530 and fix it if it is affected.

What it is: CVE-2024-10530 is a medium-severity missing authorization vulnerability in Kognetiks Chatbot for WordPress, published on 13 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-10530 in the wild and no public exploit code.

Affected product: Kognetiks Chatbot for WordPress. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-10530/ (Markdown: https://insights.sbomify.com/CVE-2024-10530/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-10530
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-10530
- OSV: https://osv.dev/vulnerability/CVE-2024-10530

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-10530/
Summaries are generated and may contain mistakes; the official description above is the record.
