CVE-2024-10792 Easiest Funnel Builder For WordPress & WooCommerce by WPFunnels <= 3.5.5 - Reflected Cross-Site Scripting

Medium 6.1 Published Updated

Unauthenticated attackers can inject arbitrary scripts via the post_id parameter, requiring user interaction to execute malicious code.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2024-10792?

CVE-2024-10792 is a medium-severity cross-site scripting vulnerability in getwpfunnels WPFunnels – Funnel Builder for WooCommerce with Checkout & One Click Upsell, published on 21 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The Easiest Funnel Builder For WordPress & WooCommerce by WPFunnels plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'post_id' parameter in all versions up to, and including, 3.5.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. This was partially patched in 3.5.4 and fully patched in 3.5.5.

Weakness: CWE-79

Which versions are affected by CVE-2024-10792?

How do I fix CVE-2024-10792?

No fix has been published for CVE-2024-10792 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-10792 being exploited?

There is no known exploitation of CVE-2024-10792 in the wild and no public exploit code.

Sources

Is CVE-2024-10792 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free