{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-10792 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-10792 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-10792 is a medium-severity cross-site scripting vulnerability in getwpfunnels WPFunnels – Funnel Builder for WooCommerce with Checkout \u0026 One Click Upsell, published on 21 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-10792 and fix it if it is affected.\n\nWhat it is: CVE-2024-10792 is a medium-severity cross-site scripting vulnerability in getwpfunnels WPFunnels – Funnel Builder for WooCommerce with Checkout \u0026 One Click Upsell, published on 21 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-10792 in the wild and no public exploit code.\n\nAffected product: getwpfunnels WPFunnels – Funnel Builder for WooCommerce with Checkout \u0026 One Click Upsell. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-10792/ (Markdown: https://insights.sbomify.com/CVE-2024-10792/index.md)","id":"CVE-2024-10792","markdown":"https://insights.sbomify.com/CVE-2024-10792/index.md","name":"CVE-2024-10792","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress funnel builder","requires_auth":"none","summary":"Unauthenticated attackers can inject arbitrary scripts via the post_id parameter, requiring user interaction to execute malicious code.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Easiest Funnel Builder For WordPress \u0026 WooCommerce by WPFunnels plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'post_id' parameter in all versions up to, and including, 3.5.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. This was partially patched in 3.5.4 and fully patched in 3.5.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Easiest Funnel Builder For WordPress \u0026 WooCommerce by WPFunnels \u003c= 3.5.5 - Reflected Cross-Site Scripting","id":"CVE-2024-10792","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":4,"next":{"headline":"WP Activity Log \u003c= 5.2.1 - Unauthenticated Stored Cross-Site Scripting via User_id Parameter","id":"CVE-2024-10793"},"packages":[],"prev":{"headline":"Codezips Hospital Appointment System doctorAction.php sql injection","id":"CVE-2024-10791"},"products":["WPFunnels – Funnel Builder for WooCommerce with Checkout \u0026 One Click Upsell"],"published":"2024-11-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["getwpfunnels"]},"summary":"Unauthenticated attackers can inject arbitrary scripts via the post_id parameter, requiring user interaction to execute malicious code.","url":"https://insights.sbomify.com/CVE-2024-10792/"}