# CVE-2024-10846: Excessive Platform Resource Consumption within a Loop when unmarshalling Compose file having recursive loop

> An attacker can cause excessive memory and CPU consumption in the compose-go library by sending malicious YAML payloads with recursive loops.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jan 2025
- **Updated:** 25 Apr 2025
- **Also known as:** AZL-55947, GHSA-36gq-35j3-p9r9, GO-2025-3412, MINI-6m36-69wc-qj23

## What is CVE-2024-10846?

CVE-2024-10846 is a medium-severity denial of service vulnerability in compose-spec compose-go, published on 23 Jan 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

The compose-go library component in versions v2.10-v2.4.0 allows an authorized user who sends malicious YAML payloads to cause the compose-go to consume excessive amount of Memory and CPU cycles while parsing YAML, such as used by Docker Compose from versions  v2.27.0 to v2.29.7 included

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-10846?

3 open source packages ship an affected version, including github.com/compose-spec/compose-go/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/compose-spec/compose-go/v2` | Go | From 2.1.0 | 2.4.1 |
| `github.com/compose-spec/compose-go/v2` | Go | From 2.1.0 | 2.4.1 |
| `github.com/compose-spec/compose-go/v2` | Go | From 2.1.0 | 2.4.1 |

## How do I fix CVE-2024-10846?

Upgrade github.com/compose-spec/compose-go/v2 to 2.4.1 or later.

## Is CVE-2024-10846 being exploited?

There is no known exploitation of CVE-2024-10846 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-10846 and fix it if it is affected.

What it is: CVE-2024-10846 is a medium-severity denial of service vulnerability in compose-spec compose-go, published on 23 Jan 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-10846 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/compose-spec/compose-go/v2 (Go): affected from 2.1.0; fixed in 2.4.1
- github.com/compose-spec/compose-go/v2 (Go): affected from 2.1.0; fixed in 2.4.1
- github.com/compose-spec/compose-go/v2 (Go): affected from 2.1.0; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-10846/ (Markdown: https://insights.sbomify.com/CVE-2024-10846/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-10846
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-10846
- OSV: https://osv.dev/vulnerability/CVE-2024-10846

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-10846/
Summaries are generated and may contain mistakes; the official description above is the record.
