CVE-2024-10909 Pojo Forms <= 1.4.7 - Authenticated (Subscriber+) Arbitrary Shortcode Execution via form_preview_shortcode

Medium 6.3 Published Updated

Authenticated attackers can execute arbitrary shortcodes in Pojo Forms plugin due to improper validation, potentially leading to code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-10909?

CVE-2024-10909 is a medium-severity code injection vulnerability in kingyes Pojo Forms, published on 6 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The The Pojo Forms plugin for WordPress is vulnerable to arbitrary shortcode execution via form_preview_shortcode AJAX action in all versions up to, and including, 1.4.7. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary shortcodes. This was partially fixed in version 1.4.8.

Weakness: CWE-94

Which versions are affected by CVE-2024-10909?

How do I fix CVE-2024-10909?

No fix has been published for CVE-2024-10909 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-10909 being exploited?

There is no known exploitation of CVE-2024-10909 in the wild and no public exploit code.

Sources

Also known as GHSA-54cc-8pj6-f4vw.

Is CVE-2024-10909 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free