# CVE-2024-10909: Pojo Forms <= 1.4.7 - Authenticated (Subscriber+) Arbitrary Shortcode Execution via form_preview_shortcode

> Authenticated attackers can execute arbitrary shortcodes in Pojo Forms plugin due to improper validation, potentially leading to code execution.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Dec 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-54cc-8pj6-f4vw

## What is CVE-2024-10909?

CVE-2024-10909 is a medium-severity code injection vulnerability in kingyes Pojo Forms, published on 6 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The The Pojo Forms plugin for WordPress is vulnerable to arbitrary shortcode execution via form_preview_shortcode AJAX action in all versions up to, and including, 1.4.7. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary shortcodes. This was partially fixed in version 1.4.8.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-10909?


## How do I fix CVE-2024-10909?

No fix has been published for CVE-2024-10909 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-10909 being exploited?

There is no known exploitation of CVE-2024-10909 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-10909 and fix it if it is affected.

What it is: CVE-2024-10909 is a medium-severity code injection vulnerability in kingyes Pojo Forms, published on 6 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-10909 in the wild and no public exploit code.

Affected product: kingyes Pojo Forms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-10909/ (Markdown: https://insights.sbomify.com/CVE-2024-10909/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-10909
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-10909
- OSV: https://osv.dev/vulnerability/CVE-2024-10909

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-10909/
Summaries are generated and may contain mistakes; the official description above is the record.
