CVE-2024-10921 Improper neutralization of null bytes may lead to buffer over-reads in MongoDB Server

Medium 6.8 Published Updated

An authorized user can cause server crashes or read sensitive memory contents by sending malformed BSON requests to MongoDB Server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-10921?

CVE-2024-10921 is a medium-severity memory corruption vulnerability in Mongodb Mongodb, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An authorized user may trigger crashes or receive the contents of buffer over-reads of Server memory by issuing specially crafted requests that construct malformed BSON in the MongoDB Server. This issue affects MongoDB Server v5.0 versions prior to 5.0.30 , MongoDB Server v6.0 versions prior to 6.0.19, MongoDB Server v7.0 versions prior to 7.0.15 and MongoDB Server v8.0 versions prior to and including 8.0.2.

Weakness: CWE-158

Which versions are affected by CVE-2024-10921?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 5.0.05.0.30, 6.0.19, 7.0.15, 8.0.3

Products include Mongodb Mongodb.

How do I fix CVE-2024-10921?

Upgrade mongodb to a fixed version for your release line: 5.0.30, 6.0.19, 7.0.15 or 8.0.3.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2024-10921 being exploited?

There is no known exploitation of CVE-2024-10921 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2024-10921, GHSA-rvjg-858g-pwh4, UBUNTU-CVE-2024-10921.

Is CVE-2024-10921 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free