# CVE-2024-10921: Improper neutralization of null bytes may lead to buffer over-reads in MongoDB Server

> An authorized user can cause server crashes or read sensitive memory contents by sending malformed BSON requests to MongoDB Server.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2024
- **Updated:** 15 Nov 2024
- **Also known as:** BIT-mongodb-2024-10921, GHSA-rvjg-858g-pwh4, UBUNTU-CVE-2024-10921

## What is CVE-2024-10921?

CVE-2024-10921 is a medium-severity memory corruption vulnerability in Mongodb Mongodb, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An authorized user may trigger crashes or receive the contents of buffer over-reads of Server memory by issuing specially crafted requests that construct malformed BSON in the MongoDB Server. This issue affects MongoDB Server v5.0 versions prior to 5.0.30 , MongoDB Server v6.0 versions prior to 6.0.19, MongoDB Server v7.0 versions prior to 7.0.15 and MongoDB Server v8.0 versions prior to and including 8.0.2.

Weakness: CWE-158 (Improper Neutralization of Null Byte or NUL Character)

## Which versions are affected by CVE-2024-10921?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 5.0.0 | 5.0.30, 6.0.19, 7.0.15, 8.0.3 |

Products: Mongodb Mongodb.

## How do I fix CVE-2024-10921?

Upgrade mongodb to a fixed version for your release line: 5.0.30, 6.0.19, 7.0.15 or 8.0.3.

## Is CVE-2024-10921 being exploited?

There is no known exploitation of CVE-2024-10921 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-10921 and fix it if it is affected.

What it is: CVE-2024-10921 is a medium-severity memory corruption vulnerability in Mongodb Mongodb, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-10921 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 5.0.0; fixed in 5.0.30, 6.0.19, 7.0.15, 8.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-10921/ (Markdown: https://insights.sbomify.com/CVE-2024-10921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-10921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-10921
- OSV: https://osv.dev/vulnerability/CVE-2024-10921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-10921/
Summaries are generated and may contain mistakes; the official description above is the record.
