# CVE-2024-10973: Keycloak: cli option for encrypted jgroups ignored

> An attacker on the adjacent network can read sensitive JGroups replication data because the encrypted transport configuration is ignored.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2024
- **Updated:** 8 Aug 2026
- **Also known as:** ECHO-6e54-de1b-08c9, GHSA-g6qq-c9f9-2772

## What is CVE-2024-10973?

CVE-2024-10973 is a medium-severity vulnerability in Red Hat Build of Keycloak, published on 17 Dec 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in Keycloak. The environment option `KC_CACHE_EMBEDDED_MTLS_ENABLED` does not work and the JGroups replication configuration is always used in plain text which can allow an attacker that has access to adjacent networks related to JGroups to read sensitive information.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2024-10973?

2 open source packages ship an affected version, including org.keycloak:keycloak-quarkus-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-quarkus-server` | Maven | From 25.0.0 | 26.0.6 |
| `org.keycloak:keycloak-quarkus-server` | Maven | From 25.0.0 | 26.0.6 |

## How do I fix CVE-2024-10973?

Upgrade org.keycloak:keycloak-quarkus-server to 26.0.6 or later.

## Is CVE-2024-10973 being exploited?

There is no known exploitation of CVE-2024-10973 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-10973 and fix it if it is affected.

What it is: CVE-2024-10973 is a medium-severity vulnerability in Red Hat Build of Keycloak, published on 17 Dec 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-10973 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-quarkus-server (Maven): affected from 25.0.0; fixed in 26.0.6
- org.keycloak:keycloak-quarkus-server (Maven): affected from 25.0.0; fixed in 26.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-10973/ (Markdown: https://insights.sbomify.com/CVE-2024-10973/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-10973
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-10973
- OSV: https://osv.dev/vulnerability/CVE-2024-10973

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-10973/
Summaries are generated and may contain mistakes; the official description above is the record.
