CVE-2024-10975 Nomad Vulnerable To Cross-Namespace Volume Creation Abusing CSI Write Permission

High 7.7 Published Updated

Attackers can create volumes in unauthorized namespaces via CSI write permissions, requiring an upgrade to patched Nomad versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-10975?

CVE-2024-10975 is a high-severity missing authorization vulnerability in HashiCorp Nomad, published on 7 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.

Weakness: CWE-863

Which versions are affected by CVE-2024-10975?

3 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.

PackageAffectedFixed in
github.com/hashicorp/nomad GoAll versions to 1.9.1None
github.com/hashicorp/nomad GoAll versions to 1.9.1None
github.com/hashicorp/nomad GoAll versions1.9.2

Products include Hashicorp Nomad.

How do I fix CVE-2024-10975?

Upgrade github.com/hashicorp/nomad to 1.9.2 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-10975 being exploited?

There is no known exploitation of CVE-2024-10975 in the wild and no public exploit code.

Sources

Also known as GHSA-2w5v-x29g-jw7j, GO-2024-3262, UBUNTU-CVE-2024-10975.

Is CVE-2024-10975 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free