# CVE-2024-10975: Nomad Vulnerable To Cross-Namespace Volume Creation Abusing CSI Write Permission

> Attackers can create volumes in unauthorized namespaces via CSI write permissions, requiring an upgrade to patched Nomad versions.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2024
- **Updated:** 7 Nov 2024
- **Also known as:** GHSA-2w5v-x29g-jw7j, GO-2024-3262, UBUNTU-CVE-2024-10975

## What is CVE-2024-10975?

CVE-2024-10975 is a high-severity missing authorization vulnerability in HashiCorp Nomad, published on 7 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-10975?

3 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/nomad` | Go | All versions to 1.9.1 | None |
| `github.com/hashicorp/nomad` | Go | All versions to 1.9.1 | None |
| `github.com/hashicorp/nomad` | Go | All versions | 1.9.2 |

Products: Hashicorp Nomad.

## How do I fix CVE-2024-10975?

Upgrade github.com/hashicorp/nomad to 1.9.2 or later.

## Is CVE-2024-10975 being exploited?

There is no known exploitation of CVE-2024-10975 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Nomad

- [CVE-2023-1782](https://insights.sbomify.com/CVE-2023-1782/): Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation (critical 10.0)
- [CVE-2022-30324](https://insights.sbomify.com/CVE-2022-30324/): Privilege escalation in Hashicorp Nomad (critical 9.8)
- [CVE-2020-7956](https://insights.sbomify.com/CVE-2020-7956/): Improper Certificate Validation in HashiCorp Nomad (critical 9.8)
- [CVE-2019-12618](https://insights.sbomify.com/CVE-2019-12618/): Hashicorp Nomad Access Control Issues (critical 9.8)
- [CVE-2020-27195](https://insights.sbomify.com/CVE-2020-27195/): Use After Free in HashiCorp Nomad (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-10975 and fix it if it is affected.

What it is: CVE-2024-10975 is a high-severity missing authorization vulnerability in HashiCorp Nomad, published on 7 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-10975 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/nomad (Go): affected all versions up to 1.9.1; no fix listed
- github.com/hashicorp/nomad (Go): affected all versions up to 1.9.1; no fix listed
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 1.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-10975/ (Markdown: https://insights.sbomify.com/CVE-2024-10975/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-10975
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-10975
- OSV: https://osv.dev/vulnerability/CVE-2024-10975

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-10975/
Summaries are generated and may contain mistakes; the official description above is the record.
