{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-10976 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 13.17.0, 14.14.0, 15.9.0 or 16.5.0.","what":"CVE-2024-10976 is a medium-severity missing authorization vulnerability in Postgresql Postgresql, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-10976 and fix it if it is affected.\n\nWhat it is: CVE-2024-10976 is a medium-severity missing authorization vulnerability in Postgresql Postgresql, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-10976 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected all versions; fixed in 13.17.0, 14.14.0, 15.9.0, 16.5.0, 17.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-10976/ (Markdown: https://insights.sbomify.com/CVE-2024-10976/index.md)","id":"CVE-2024-10976","markdown":"https://insights.sbomify.com/CVE-2024-10976/index.md","name":"CVE-2024-10976","record":{"aliases":["ALPINE-CVE-2024-10976","AZL-53201","AZL-53215","BELL-CVE-2024-10976","BIT-postgresql-2024-10976","CLEANSTART-2026-WJ73898","DEBIAN-CVE-2024-10976","ECHO-ad9b-90ea-d778","GHSA-9cv8-8vgq-fg45","JLSEC-2026-47","MINI-72hp-c2rh-4xm4","MINI-8c9j-65w8-cggv","MINI-wppg-x4q6-v969","UBUNTU-CVE-2024-10976"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"PostgreSQL database","requires_auth":"low_privilege","summary":"Attackers can bypass row-level security policies in PostgreSQL to read or modify unauthorized data when query plans are reused across role changes.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-1250","name":"Improper Preservation of Consistency Between Independent Representations of Shared State"}],"description":"Incomplete tracking in PostgreSQL of tables with row security allows a reused query to view or change different rows from those intended.  CVE-2023-2455 and CVE-2016-2193 fixed most interaction between row security and user ID changes.  They missed cases where a subquery, WITH query, security invoker view, or SQL-language function references a table with a row-level security policy.  This has the same consequences as the two earlier CVEs.  That is to say, it leads to potentially incorrect policies being applied in cases where role-specific policies are used and a given query is planned under one role and then executed under other roles.  This scenario can happen under security definer functions or when a common user and query is planned initially and then re-used across multiple SET ROLEs.  Applying an incorrect policy may permit a user to complete otherwise-forbidden reads and modifications.  This affects only databases that have used CREATE POLICY to define a row security policy.  An attacker must tailor an attack to a particular application's pattern of query plan reuse, user ID changes, and role-specific row security policies.  Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PostgreSQL row security below e.g. subqueries disregards user ID changes","id":"CVE-2024-10976","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"postgresql:postgresql","products":["postgresql:postgresql"],"type":"missing_authorization","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"PostgreSQL libpq retains an error message from man-in-the-middle","id":"CVE-2024-10977"},"packages":[{"ecosystem":"Bitnami","fixed":["13.17.0","14.14.0","15.9.0","16.5.0","17.1.0"],"introduced":["0","14.0.0","15.0.0","16.0.0","17.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2024-10976"}],"prev":{"headline":"Nomad Vulnerable To Cross-Namespace Volume Creation Abusing CSI Write Permission","id":"CVE-2024-10975"},"products":["PostgreSQL"],"published":"2024-11-14","related":[{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1902","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1903","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2007-3279","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2002-1399","kev_date_added":null,"published":"2003-01-08"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2016-3065","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2007-3280","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":8.8,"headline":"PostgreSQL tsvector and tsquery undersize allocations, via integer wraparound","id":"CVE-2026-14662","kev_date_added":null,"published":"2026-08-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["n/a"]},"summary":"Attackers can bypass row-level security policies in PostgreSQL to read or modify unauthorized data when query plans are reused across role changes.","url":"https://insights.sbomify.com/CVE-2024-10976/"}