{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-10977 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 12.21.0, 13.17.0, 14.14.0 or 15.9.0.","what":"CVE-2024-10977 is a low-severity vulnerability in Postgresql Postgresql, published on 14 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-10977 and fix it if it is affected.\n\nWhat it is: CVE-2024-10977 is a low-severity vulnerability in Postgresql Postgresql, published on 14 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-10977 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected all versions; fixed in 12.21.0, 13.17.0, 14.14.0, 15.9.0, 16.5.0, 17.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-10977/ (Markdown: https://insights.sbomify.com/CVE-2024-10977/index.md)","id":"CVE-2024-10977","markdown":"https://insights.sbomify.com/CVE-2024-10977/index.md","name":"CVE-2024-10977","record":{"aliases":["ALPINE-CVE-2024-10977","AZL-53195","AZL-53206","BELL-CVE-2024-10977","BIT-postgresql-2024-10977","CLEANSTART-2026-AH36441","CLSA-2026-1779707025","DEBIAN-CVE-2024-10977","ECHO-84d0-1dcb-0c06","GHSA-62q4-hc79-94qj","JLSEC-2026-48","MINI-5mr4-xr4r-878x","MINI-8w32-ppgh-q5qj","MINI-xm6g-qh5r-pxpx","UBUNTU-CVE-2024-10977"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL database","requires_auth":"none","summary":"A man-in-the-middle attacker can inject arbitrary error messages into PostgreSQL clients, potentially misleading users or screen scrapers into treating them as valid data.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"},{"id":"CWE-348","name":"Use of Less Trusted Source"}],"description":"Client use of server error message in PostgreSQL allows a server not trusted under current SSL or GSS settings to furnish arbitrary non-NUL bytes to the libpq application.  For example, a man-in-the-middle attacker could send a long error message that a human or screen-scraper user of psql mistakes for valid query results.  This is probably not a concern for clients where the user interface unambiguously indicates the boundary between one error message and other text.  Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PostgreSQL libpq retains an error message from man-in-the-middle","id":"CVE-2024-10977","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"postgresql:postgresql","products":["postgresql:postgresql"],"type":"information_disclosure","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"PostgreSQL SET ROLE, SET SESSION AUTHORIZATION reset to wrong user ID","id":"CVE-2024-10978"},"packages":[{"ecosystem":"Bitnami","fixed":["12.21.0","13.17.0","14.14.0","15.9.0","16.5.0","17.1.0"],"introduced":["0","13.0.0","14.0.0","15.0.0","16.0.0","17.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2024-10977"}],"prev":{"headline":"PostgreSQL row security below e.g. subqueries disregards user ID changes","id":"CVE-2024-10976"},"products":["PostgreSQL"],"published":"2024-11-14","related":[{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1902","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1903","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2007-3279","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2002-1399","kev_date_added":null,"published":"2003-01-08"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2016-3065","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2007-3280","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":8.8,"headline":"PostgreSQL tsvector and tsquery undersize allocations, via integer wraparound","id":"CVE-2026-14662","kev_date_added":null,"published":"2026-08-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["n/a"]},"summary":"A man-in-the-middle attacker can inject arbitrary error messages into PostgreSQL clients, potentially misleading users or screen scrapers into treating them as valid data.","url":"https://insights.sbomify.com/CVE-2024-10977/"}