CVE-2024-10978 PostgreSQL SET ROLE, SET SESSION AUTHORIZATION reset to wrong user ID
A privilege escalation flaw in PostgreSQL allows attackers to view or modify unintended rows when applications use SET ROLE or SET SESSION AUTHORIZATION.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-10978?
CVE-2024-10978 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Incorrect privilege assignment in PostgreSQL allows a less-privileged application user to view or change different rows from those intended. An attack requires the application to use SET ROLE, SET SESSION AUTHORIZATION, or an equivalent feature. The problem arises when an application query uses parameters from the attacker or conveys query results to the attacker. If that query reacts to current_setting('role') or the current user ID, it may modify or return data as though the session had not used SET ROLE or SET SESSION AUTHORIZATION. The attacker does not control which incorrect user ID applies. Query text from less-privileged sources is not a concern here, because SET ROLE and SET SESSION AUTHORIZATION are not sandboxes for unvetted queries. Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.
Weakness: CWE-266
Which versions are affected by CVE-2024-10978?
1 open source package ship an affected version, including postgresql. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 12.21.0, 13.17.0, 14.14.0, 15.9.0, 16.5.0, 17.1.0 |
Products include Debian Debian Linux, Postgresql Postgresql.
How do I fix CVE-2024-10978?
Upgrade postgresql to a fixed version for your release line: 12.21.0, 13.17.0, 14.14.0 or 15.9.0.
Is CVE-2024-10978 being exploited?
There is no known exploitation of CVE-2024-10978 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2024-10978, AZL-53204, AZL-53209, BELL-CVE-2024-10978, BIT-postgresql-2024-10978, CLEANSTART-2026-NO21285 and 9 more.