{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-10978 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 12.21.0, 13.17.0, 14.14.0 or 15.9.0.","what":"CVE-2024-10978 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-10978 and fix it if it is affected.\n\nWhat it is: CVE-2024-10978 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-10978 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected all versions; fixed in 12.21.0, 13.17.0, 14.14.0, 15.9.0, 16.5.0, 17.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-10978/ (Markdown: https://insights.sbomify.com/CVE-2024-10978/index.md)","id":"CVE-2024-10978","markdown":"https://insights.sbomify.com/CVE-2024-10978/index.md","name":"CVE-2024-10978","record":{"aliases":["ALPINE-CVE-2024-10978","AZL-53204","AZL-53209","BELL-CVE-2024-10978","BIT-postgresql-2024-10978","CLEANSTART-2026-NO21285","CLSA-2025-1747432102","DEBIAN-CVE-2024-10978","ECHO-9aa9-6da5-918f","GHSA-37v9-jh5m-f5pg","JLSEC-2026-49","MINI-hr34-cm42-92xw","MINI-m775-3hw9-rh8f","MINI-p54r-p98h-46w9","UBUNTU-CVE-2024-10978"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"PostgreSQL database","requires_auth":"low_privilege","summary":"A privilege escalation flaw in PostgreSQL allows attackers to view or modify unintended rows when applications use SET ROLE or SET SESSION AUTHORIZATION.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"Incorrect privilege assignment in PostgreSQL allows a less-privileged application user to view or change different rows from those intended.  An attack requires the application to use SET ROLE, SET SESSION AUTHORIZATION, or an equivalent feature.  The problem arises when an application query uses parameters from the attacker or conveys query results to the attacker.  If that query reacts to current_setting('role') or the current user ID, it may modify or return data as though the session had not used SET ROLE or SET SESSION AUTHORIZATION.  The attacker does not control which incorrect user ID applies.  Query text from less-privileged sources is not a concern here, because SET ROLE and SET SESSION AUTHORIZATION are not sandboxes for unvetted queries.  Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PostgreSQL SET ROLE, SET SESSION AUTHORIZATION reset to wrong user ID","id":"CVE-2024-10978","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","postgresql:postgresql"],"type":"privilege_escalation","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"PostgreSQL PL/Perl environment variable changes execute arbitrary code","id":"CVE-2024-10979"},"packages":[{"ecosystem":"Bitnami","fixed":["12.21.0","13.17.0","14.14.0","15.9.0","16.5.0","17.1.0"],"introduced":["0","13.0.0","14.0.0","15.0.0","16.0.0","17.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2024-10978"}],"prev":{"headline":"PostgreSQL libpq retains an error message from man-in-the-middle","id":"CVE-2024-10977"},"products":["PostgreSQL"],"published":"2024-11-14","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["n/a"]},"summary":"A privilege escalation flaw in PostgreSQL allows attackers to view or modify unintended rows when applications use SET ROLE or SET SESSION AUTHORIZATION.","url":"https://insights.sbomify.com/CVE-2024-10978/"}