{"answers":{"affected":"2 open source packages ship an affected version, including firebase. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-11023 in the wild and no public exploit code.","fix":"Upgrade firebase to 10.9.0 or later.","what":"CVE-2024-11023 is a medium-severity authentication bypass vulnerability in Firebase JavaScript SDK, published on 18 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-11023 and fix it if it is affected.\n\nWhat it is: CVE-2024-11023 is a medium-severity authentication bypass vulnerability in Firebase JavaScript SDK, published on 18 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-11023 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- firebase (npm): affected all versions; fixed in 10.9.0\n- firebase (npm): affected all versions; fixed in 10.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-11023/ (Markdown: https://insights.sbomify.com/CVE-2024-11023/index.md)","id":"CVE-2024-11023","markdown":"https://insights.sbomify.com/CVE-2024-11023/index.md","name":"CVE-2024-11023","record":{"aliases":["GHSA-3wf4-68gx-mph8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Firebase JavaScript SDK","requires_auth":"low_privilege","summary":"Attackers can hijack user sessions by manipulating the Firebase defaults cookie to redirect authentication tokens to a malicious server.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Google","cpe":[{"product":"firebase_javascript_sdk","vendor":"google"}],"cvss":{"score":5.2,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:A/VC:L/VI:L/VA:L/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Firebase JavaScript SDK utilizes a \"FIREBASE_DEFAULTS\" cookie to store configuration data, including an \"_authTokenSyncURL\" field used for session synchronization.  If this cookie field is preset via an attacker by any other method, the attacker can manipulate the \"_authTokenSyncURL\" to point to their own server and it would allow an actor to capture user session data transmitted by the SDK. We recommend upgrading Firebase JS SDK at least to 10.9.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Session Hijacking in Firebase JavaScript SDK","id":"CVE-2024-11023","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"AppPresser – Mobile App Framework \u003c= 4.4.6 - Unauthenticated Privilege Escalation via Password Reset","id":"CVE-2024-11024"},"packages":[{"ecosystem":"npm","fixed":["10.9.0"],"introduced":["0"],"last_affected":[],"package":"firebase","purl":null,"source":"GHSA-3wf4-68gx-mph8"},{"ecosystem":"npm","fixed":["10.9.0"],"introduced":["0"],"last_affected":[],"package":"firebase","purl":"pkg:npm/firebase","source":"GHSA-3wf4-68gx-mph8"}],"prev":{"headline":"SICK InspectorP61x and SICK InspectorP62x are vulnerable for a replay attack","id":"CVE-2024-11022"},"products":["JavaScript SDK"],"published":"2024-11-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-18","vendors":["Firebase"]},"summary":"Attackers can hijack user sessions by manipulating the Firebase defaults cookie to redirect authentication tokens to a malicious server.","url":"https://insights.sbomify.com/CVE-2024-11023/"}