{"answers":{"affected":"3 open source packages ship an affected version, including invokeai and InvokeAI.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11042 exists.","fix":"Upgrade invokeai to 5.3.0rc1 or later.","what":"CVE-2024-11042 is a critical path traversal vulnerability in invoke-ai/invokeai, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-11042 and fix it if it is affected.\n\nWhat it is: CVE-2024-11042 is a critical path traversal vulnerability in invoke-ai/invokeai, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11042 exists.\n\nAffected packages and fixed versions:\n- invokeai (PyPI): affected all versions; fixed in 5.3.0rc1\n- invokeai (PyPI): affected all versions; fixed in 5.3.0rc1\n- InvokeAI (PyPI): affected all versions; fixed in 5.3.0rc1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-11042/ (Markdown: https://insights.sbomify.com/CVE-2024-11042/index.md)","id":"CVE-2024-11042","markdown":"https://insights.sbomify.com/CVE-2024-11042/index.md","name":"CVE-2024-11042","record":{"aliases":["GHSA-227r-w5j2-6243","PYSEC-2026-358"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"AI image generation app","requires_auth":"none","summary":"Attackers can delete arbitrary files on the server via the image deletion API, compromising system integrity and availability.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-73","name":"External Control of File Name or Path"}],"description":"In invoke-ai/invokeai version v5.0.2, the web API `POST /api/v1/images/delete` is vulnerable to Arbitrary File Deletion. This vulnerability allows unauthorized attackers to delete arbitrary files on the server, potentially including critical or sensitive system files such as SSH keys, SQLite databases, and configuration files. This can impact the integrity and availability of applications relying on these files.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2025-03-21","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-03-21T16:55:49Z","kind":"github_poc","ref":"https://github.com/gothburz/CVE-2024-11042","stars":0,"title":"Proof-of-concept for In invoke-ai/invokeai version v5.0.2 Arbitrary File Deletion."}],"tier":"weaponised"},"has_fix":true,"headline":"Arbitrary File Delete in invoke-ai/invokeai","id":"CVE-2024-11042","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Denial of Service (DoS) via Large Payload in Board Name Field in invoke-ai/invokeai","id":"CVE-2024-11043"},"packages":[{"ecosystem":"PyPI","fixed":["5.3.0rc1"],"introduced":["0"],"last_affected":[],"package":"InvokeAI","purl":null,"source":"GHSA-227r-w5j2-6243"},{"ecosystem":"PyPI","fixed":["5.3.0rc1"],"introduced":["0"],"last_affected":[],"package":"invokeai","purl":"pkg:pypi/invokeai","source":"GHSA-227r-w5j2-6243"},{"ecosystem":"PyPI","fixed":["5.3.0rc1"],"introduced":["0"],"last_affected":[],"package":"invokeai","purl":"pkg:pypi/invokeai","source":"PYSEC-2026-358"}],"prev":{"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041"},"products":["invoke-ai/invokeai"],"published":"2025-03-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-15","vendors":["invoke-ai"]},"summary":"Attackers can delete arbitrary files on the server via the image deletion API, compromising system integrity and availability.","url":"https://insights.sbomify.com/CVE-2024-11042/"}