# CVE-2024-11042: Arbitrary File Delete in invoke-ai/invokeai

> Attackers can delete arbitrary files on the server via the image deletion API, compromising system integrity and availability.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-227r-w5j2-6243, PYSEC-2026-358

## What is CVE-2024-11042?

CVE-2024-11042 is a critical path traversal vulnerability in invoke-ai/invokeai, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In invoke-ai/invokeai version v5.0.2, the web API `POST /api/v1/images/delete` is vulnerable to Arbitrary File Deletion. This vulnerability allows unauthorized attackers to delete arbitrary files on the server, potentially including critical or sensitive system files such as SSH keys, SQLite databases, and configuration files. This can impact the integrity and availability of applications relying on these files.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2024-11042?

3 open source packages ship an affected version, including invokeai and InvokeAI.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `invokeai` | PyPI | All versions | 5.3.0rc1 |
| `invokeai` | PyPI | All versions | 5.3.0rc1 |
| `InvokeAI` | PyPI | All versions | 5.3.0rc1 |

## How do I fix CVE-2024-11042?

Upgrade invokeai to 5.3.0rc1 or later.

## Is CVE-2024-11042 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11042 exists.

Public exploit code:

- Proof-of-concept for In invoke-ai/invokeai version v5.0.2 Arbitrary File Deletion. (github_poc): https://github.com/gothburz/CVE-2024-11042

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11042 and fix it if it is affected.

What it is: CVE-2024-11042 is a critical path traversal vulnerability in invoke-ai/invokeai, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11042 exists.

Affected packages and fixed versions:
- invokeai (PyPI): affected all versions; fixed in 5.3.0rc1
- invokeai (PyPI): affected all versions; fixed in 5.3.0rc1
- InvokeAI (PyPI): affected all versions; fixed in 5.3.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11042/ (Markdown: https://insights.sbomify.com/CVE-2024-11042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11042
- OSV: https://osv.dev/vulnerability/CVE-2024-11042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11042/
Summaries are generated and may contain mistakes; the official description above is the record.
