CVE-2024-11233 Single byte overread with convert.quoted-printable-decode filter
A single-byte overread in PHP's quoted-printable-decode filter can disclose memory contents or cause crashes, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-11233?
CVE-2024-11233 is a medium-severity vulnerability in Php Php, published on 24 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, due to an error in convert.quoted-printable-decode filter certain data can lead to buffer overread by one byte, which can in certain circumstances lead to crashes or disclose content of other memory areas.
Which versions are affected by CVE-2024-11233?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |
php Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |
php-min Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |
Products include Php Php.
How do I fix CVE-2024-11233?
Upgrade libphp to a fixed version for your release line: 8.1.31, 8.2.26 or 8.3.14.
Is CVE-2024-11233 being exploited?
There is no known exploitation of CVE-2024-11233 in the wild and no public exploit code.
Other vulnerabilities in Php Php
Sources
Also known as AZL-53462, AZL-53634, BELL-CVE-2024-11233, BIT-libphp-2024-11233, BIT-php-2024-11233, BIT-php-min-2024-11233 and 16 more.