{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-11233 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.31, 8.2.26 or 8.3.14.","what":"CVE-2024-11233 is a medium-severity vulnerability in Php Php, published on 24 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-11233 and fix it if it is affected.\n\nWhat it is: CVE-2024-11233 is a medium-severity vulnerability in Php Php, published on 24 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-11233 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14\n- php (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14\n- php-min (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-11233/ (Markdown: https://insights.sbomify.com/CVE-2024-11233/index.md)","id":"CVE-2024-11233","markdown":"https://insights.sbomify.com/CVE-2024-11233/index.md","name":"CVE-2024-11233","record":{"aliases":["AZL-53462","AZL-53634","BELL-CVE-2024-11233","BIT-libphp-2024-11233","BIT-php-2024-11233","BIT-php-min-2024-11233","CLSA-2024-1733246329","CLSA-2024-1733421975","CLSA-2024-1733422173","CLSA-2024-1733429914","CLSA-2024-1733908995","CLSA-2024-1734368527","CLSA-2024-1734543983","CLSA-2024-1735065830","CLSA-2024-1735310784","DEBIAN-CVE-2024-11233","ECHO-588d-cb65-535a","GHSA-r977-prxv-hc43","MINI-74xp-w959-3435","MINI-89pm-jg25-wv6x","MINI-rxp6-r9pm-r9cx","UBUNTU-CVE-2024-11233"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP scripting language","requires_auth":"none","summary":"A single-byte overread in PHP's quoted-printable-decode filter can disclose memory contents or cause crashes, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, due to an error in convert.quoted-printable-decode filter certain data can lead to buffer overread by one byte, which can in certain circumstances lead to crashes or disclose content of other memory areas.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Single byte overread with convert.quoted-printable-decode filter","id":"CVE-2024-11233","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"information_disclosure","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Configuring a proxy in a stream context might allow for CRLF injection in URIs","id":"CVE-2024-11234"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.31","8.2.26","8.3.14"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2024-11233"},{"ecosystem":"Bitnami","fixed":["8.1.31","8.2.26","8.3.14"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2024-11233"},{"ecosystem":"Bitnami","fixed":["8.1.31","8.2.26","8.3.14"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2024-11233"}],"prev":{"headline":"우커머스 네이버페이 \u003c= 3.3.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via mnp_purchase Shortcode","id":"CVE-2024-11231"},"products":["PHP"],"published":"2024-11-24","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["PHP Group"]},"summary":"A single-byte overread in PHP's quoted-printable-decode filter can disclose memory contents or cause crashes, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2024-11233/"}