# CVE-2024-11233: Single byte overread with convert.quoted-printable-decode filter

> A single-byte overread in PHP's quoted-printable-decode filter can disclose memory contents or cause crashes, requiring an upgrade to patched versions.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-53462, AZL-53634, BELL-CVE-2024-11233, BIT-libphp-2024-11233, BIT-php-2024-11233, BIT-php-min-2024-11233, CLSA-2024-1733246329, CLSA-2024-1733421975, CLSA-2024-1733422173, CLSA-2024-1733429914, CLSA-2024-1733908995, CLSA-2024-1734368527, CLSA-2024-1734543983, CLSA-2024-1735065830, CLSA-2024-1735310784, DEBIAN-CVE-2024-11233, ECHO-588d-cb65-535a, GHSA-r977-prxv-hc43, MINI-74xp-w959-3435, MINI-89pm-jg25-wv6x, MINI-rxp6-r9pm-r9cx, UBUNTU-CVE-2024-11233

## What is CVE-2024-11233?

CVE-2024-11233 is a medium-severity vulnerability in Php Php, published on 24 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, due to an error in convert.quoted-printable-decode filter certain data can lead to buffer overread by one byte, which can in certain circumstances lead to crashes or disclose content of other memory areas.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2024-11233?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |
| `php` | Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |
| `php-min` | Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |

Products: Php Php.

## How do I fix CVE-2024-11233?

Upgrade libphp to a fixed version for your release line: 8.1.31, 8.2.26 or 8.3.14.

## Is CVE-2024-11233 being exploited?

There is no known exploitation of CVE-2024-11233 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11233 and fix it if it is affected.

What it is: CVE-2024-11233 is a medium-severity vulnerability in Php Php, published on 24 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-11233 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14
- php (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14
- php-min (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11233/ (Markdown: https://insights.sbomify.com/CVE-2024-11233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11233
- OSV: https://osv.dev/vulnerability/CVE-2024-11233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11233/
Summaries are generated and may contain mistakes; the official description above is the record.
