CVE-2024-11234 Configuring a proxy in a stream context might allow for CRLF injection in URIs
Attackers can exploit improper URI sanitization in PHP stream contexts with proxy settings to perform HTTP request smuggling and access internal resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-11234?
CVE-2024-11234 is a medium-severity server-side request forgery vulnerability in Php Php, published on 24 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, when using streams with configured proxy and "request_fulluri" option, the URI is not properly sanitized which can lead to HTTP request smuggling and allow the attacker to use the proxy to perform arbitrary HTTP requests originating from the server, thus potentially gaining access to resources not normally available to the external user.
Which versions are affected by CVE-2024-11234?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |
php Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |
php-min Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |
Products include Php Php.
How do I fix CVE-2024-11234?
Upgrade libphp to a fixed version for your release line: 8.1.31, 8.2.26 or 8.3.14.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2024-11234 being exploited?
There is no known exploitation of CVE-2024-11234 in the wild and no public exploit code.
Other vulnerabilities in Php Php
Sources
Also known as AZL-53486, AZL-53613, BELL-CVE-2024-11234, BIT-libphp-2024-11234, BIT-php-2024-11234, BIT-php-min-2024-11234 and 15 more.