{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-11234 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.31, 8.2.26 or 8.3.14.","what":"CVE-2024-11234 is a medium-severity server-side request forgery vulnerability in Php Php, published on 24 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-11234 and fix it if it is affected.\n\nWhat it is: CVE-2024-11234 is a medium-severity server-side request forgery vulnerability in Php Php, published on 24 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-11234 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14\n- php (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14\n- php-min (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-11234/ (Markdown: https://insights.sbomify.com/CVE-2024-11234/index.md)","id":"CVE-2024-11234","markdown":"https://insights.sbomify.com/CVE-2024-11234/index.md","name":"CVE-2024-11234","record":{"aliases":["AZL-53486","AZL-53613","BELL-CVE-2024-11234","BIT-libphp-2024-11234","BIT-php-2024-11234","BIT-php-min-2024-11234","CLSA-2024-1733158948","CLSA-2024-1734006823","CLSA-2024-1734039943","CLSA-2024-1734368826","CLSA-2024-1734704732","CLSA-2024-1735046232","CLSA-2024-1735064231","CLSA-2024-1735132237","DEBIAN-CVE-2024-11234","ECHO-546d-6bcc-39c3","GHSA-c5f2-jwm7-mmq2","MINI-2mmq-j3v9-6h6g","MINI-5gf4-6622-ph69","MINI-hpf6-9g33-qrx6","UBUNTU-CVE-2024-11234"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP scripting language","requires_auth":"none","summary":"Attackers can exploit improper URI sanitization in PHP stream contexts with proxy settings to perform HTTP request smuggling and access internal resources.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, when using streams with configured proxy and \"request_fulluri\" option, the URI is not properly sanitized which can lead to HTTP request smuggling and allow the attacker to use the proxy to perform arbitrary HTTP requests originating from the server, thus potentially gaining access to resources not normally available to the external user.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Configuring a proxy in a stream context might allow for CRLF injection in URIs","id":"CVE-2024-11234","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"ssrf","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Reference counting in php_request_shutdown causes Use-After-Free","id":"CVE-2024-11235"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.31","8.2.26","8.3.14"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2024-11234"},{"ecosystem":"Bitnami","fixed":["8.1.31","8.2.26","8.3.14"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2024-11234"},{"ecosystem":"Bitnami","fixed":["8.1.31","8.2.26","8.3.14"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2024-11234"}],"prev":{"headline":"Single byte overread with convert.quoted-printable-decode filter","id":"CVE-2024-11233"},"products":["PHP"],"published":"2024-11-24","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["PHP Group"]},"summary":"Attackers can exploit improper URI sanitization in PHP stream contexts with proxy settings to perform HTTP request smuggling and access internal resources.","url":"https://insights.sbomify.com/CVE-2024-11234/"}