# CVE-2024-11234: Configuring a proxy in a stream context might allow for CRLF injection in URIs

> Attackers can exploit improper URI sanitization in PHP stream contexts with proxy settings to perform HTTP request smuggling and access internal resources.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-53486, AZL-53613, BELL-CVE-2024-11234, BIT-libphp-2024-11234, BIT-php-2024-11234, BIT-php-min-2024-11234, CLSA-2024-1733158948, CLSA-2024-1734006823, CLSA-2024-1734039943, CLSA-2024-1734368826, CLSA-2024-1734704732, CLSA-2024-1735046232, CLSA-2024-1735064231, CLSA-2024-1735132237, DEBIAN-CVE-2024-11234, ECHO-546d-6bcc-39c3, GHSA-c5f2-jwm7-mmq2, MINI-2mmq-j3v9-6h6g, MINI-5gf4-6622-ph69, MINI-hpf6-9g33-qrx6, UBUNTU-CVE-2024-11234

## What is CVE-2024-11234?

CVE-2024-11234 is a medium-severity server-side request forgery vulnerability in Php Php, published on 24 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, when using streams with configured proxy and "request_fulluri" option, the URI is not properly sanitized which can lead to HTTP request smuggling and allow the attacker to use the proxy to perform arbitrary HTTP requests originating from the server, thus potentially gaining access to resources not normally available to the external user.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-11234?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |
| `php` | Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |
| `php-min` | Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |

Products: Php Php.

## How do I fix CVE-2024-11234?

Upgrade libphp to a fixed version for your release line: 8.1.31, 8.2.26 or 8.3.14.

## Is CVE-2024-11234 being exploited?

There is no known exploitation of CVE-2024-11234 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11234 and fix it if it is affected.

What it is: CVE-2024-11234 is a medium-severity server-side request forgery vulnerability in Php Php, published on 24 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-11234 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14
- php (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14
- php-min (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11234/ (Markdown: https://insights.sbomify.com/CVE-2024-11234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11234
- OSV: https://osv.dev/vulnerability/CVE-2024-11234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11234/
Summaries are generated and may contain mistakes; the official description above is the record.
