# CVE-2024-11235: Reference counting in php_request_shutdown causes Use-After-Free

> A use-after-free in PHP's request shutdown allows remote code execution if attackers control memory layout via crafted inputs.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2025
- **Updated:** 26 Feb 2026
- **Also known as:** BELL-CVE-2024-11235, BIT-libphp-2024-11235, BIT-php-2024-11235, BIT-php-min-2024-11235, CLSA-2025-1744631408, CLSA-2025-1744632037, CLSA-2025-1745956866, DEBIAN-CVE-2024-11235, GHSA-rwp7-7vc6-8477, MINI-rh74-7grw-78q2, MINI-x9vm-mv8g-q63h, UBUNTU-CVE-2024-11235

## What is CVE-2024-11235?

CVE-2024-11235 is a critical use after free vulnerability in Php Php, published on 4 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 8.3.* before 8.3.19 and 8.4.* before 8.4.5, a code sequence involving __set handler or ??=  operator and exceptions can lead to a use-after-free vulnerability. If the third party can control the memory layout leading to this, for example by supplying specially crafted inputs to the script, it could lead to remote code execution.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2024-11235?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.3.0 | 8.3.19, 8.4.5 |
| `php` | Bitnami | From 8.3.0 | 8.3.19, 8.4.5 |
| `php-min` | Bitnami | From 8.3.0 | 8.3.19, 8.4.5 |

Products: Php Php.

## How do I fix CVE-2024-11235?

Upgrade libphp to a fixed version for your release line: 8.3.19 or 8.4.5.

## Is CVE-2024-11235 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11235 exists.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11235 and fix it if it is affected.

What it is: CVE-2024-11235 is a critical use after free vulnerability in Php Php, published on 4 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11235 exists.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.3.0; fixed in 8.3.19, 8.4.5
- php (Bitnami): affected from 8.3.0; fixed in 8.3.19, 8.4.5
- php-min (Bitnami): affected from 8.3.0; fixed in 8.3.19, 8.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11235/ (Markdown: https://insights.sbomify.com/CVE-2024-11235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11235
- OSV: https://osv.dev/vulnerability/CVE-2024-11235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11235/
Summaries are generated and may contain mistakes; the official description above is the record.
