# CVE-2024-11236: Integer overflow in the firebird and dblib quoters causing OOB writes

> An integer overflow in PHP's ldap_escape function on 32-bit systems allows out-of-bounds writes, potentially leading to code execution or crashes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-53447, AZL-53718, BELL-CVE-2024-11236, BIT-libphp-2024-11236, BIT-php-2024-11236, BIT-php-min-2024-11236, DEBIAN-CVE-2024-11236, ECHO-cf7d-1ecb-9969, GHSA-5hqh-c84r-qjcv, MINI-f996-q4g7-8x8m, MINI-q7qw-v5hj-9xmq, MINI-qp5v-cpj4-x6mv, UBUNTU-CVE-2024-11236, USN-7153-1

## What is CVE-2024-11236?

CVE-2024-11236 is a critical vulnerability in Php Php, published on 24 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, uncontrolled long string inputs to ldap_escape() function on 32-bit systems can cause an integer overflow, resulting in an out-of-bounds write.

Weakness: CWE-190 (Integer Overflow or Wraparound), CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2024-11236?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |
| `php` | Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |
| `php-min` | Bitnami | All versions | 8.1.31, 8.2.26, 8.3.14 |

Products: Php Php.

## How do I fix CVE-2024-11236?

Upgrade libphp to a fixed version for your release line: 8.1.31, 8.2.26 or 8.3.14.

## Is CVE-2024-11236 being exploited?

There is no known exploitation of CVE-2024-11236 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11236 and fix it if it is affected.

What it is: CVE-2024-11236 is a critical vulnerability in Php Php, published on 24 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-11236 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14
- php (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14
- php-min (Bitnami): affected all versions; fixed in 8.1.31, 8.2.26, 8.3.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11236/ (Markdown: https://insights.sbomify.com/CVE-2024-11236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11236
- OSV: https://osv.dev/vulnerability/CVE-2024-11236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11236/
Summaries are generated and may contain mistakes; the official description above is the record.
