# CVE-2024-11394: Hugging Face Transformers Trax Model Deserialization of Untrusted Data Remote Code Execution Vulnerability

> Remote attackers can execute arbitrary code by tricking users into loading malicious model files in Hugging Face Transformers.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Nov 2024
- **Updated:** 4 Dec 2024
- **Also known as:** GHSA-hxxf-235m-72v3, PYSEC-2024-229

## What is CVE-2024-11394?

CVE-2024-11394 is a high-severity unsafe deserialization vulnerability in Hugging Face Transformers, published on 22 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Hugging Face Transformers Trax Model Deserialization of Untrusted Data Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Hugging Face Transformers. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the handling of model files. The issue results from the lack of proper validation of user-supplied data, which can result in deserialization of untrusted data. An attacker can leverage this vulnerability to execute code in the context of the current user. Was ZDI-CAN-25012.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-11394?

3 open source packages ship an affected version, including transformers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `transformers` | PyPI | All versions | 4.48.0 |
| `transformers` | PyPI | All versions | 4.48.0 |
| `transformers` | PyPI | All versions | 4.48.0 |

Products: Huggingface Transformers.

## How do I fix CVE-2024-11394?

Upgrade transformers to 4.48.0 or later.

## Is CVE-2024-11394 being exploited?

There is no known exploitation of CVE-2024-11394 in the wild and no public exploit code.

Public exploit code:

- Technical Details and Exploit for CVE-2024-11394 (github_poc): https://github.com/Piyush-Bhor/CVE-2024-11394

## Other vulnerabilities in Hugging Face Transformers

- [CVE-2023-7018](https://insights.sbomify.com/CVE-2023-7018/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.6)
- [CVE-2023-6730](https://insights.sbomify.com/CVE-2023-6730/): Deserialization of Untrusted Data in huggingface/transformers (critical 9.0)
- [CVE-2024-11393](https://insights.sbomify.com/CVE-2024-11393/): Hugging Face Transformers MaskFormer Model Deserialization of Untrusted Data Remote Code Execution Vulnerability (high 8.8)
- [CVE-2026-5241](https://insights.sbomify.com/CVE-2026-5241/): Policy Bypass in LightGlue Nested Config Resolution in huggingface/transformers (high 8.0)
- [CVE-2026-4372](https://insights.sbomify.com/CVE-2026-4372/): Arbitrary Remote Code Execution via `_attn_implementation_internal` Config Injection in huggingface/transformers (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11394 and fix it if it is affected.

What it is: CVE-2024-11394 is a high-severity unsafe deserialization vulnerability in Hugging Face Transformers, published on 22 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-11394 in the wild and no public exploit code.

Affected packages and fixed versions:
- transformers (PyPI): affected all versions; fixed in 4.48.0
- transformers (PyPI): affected all versions; fixed in 4.48.0
- transformers (PyPI): affected all versions; fixed in 4.48.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11394/ (Markdown: https://insights.sbomify.com/CVE-2024-11394/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11394
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11394
- OSV: https://osv.dev/vulnerability/CVE-2024-11394

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11394/
Summaries are generated and may contain mistakes; the official description above is the record.
