# CVE-2024-11404: File Upload Bypass in django Filer

> Attackers can upload dangerous files to execute code or inject scripts, affecting users of the django Filer library.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Nov 2024
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-j4v3-wwwx-5gqv, PYSEC-2026-1298

## What is CVE-2024-11404?

CVE-2024-11404 is a medium-severity vulnerability in django Filer, published on 20 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Unrestricted Upload of File with Dangerous Type, Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in django CMS Association django Filer allows Input Data Manipulation, Stored XSS.

This issue affects django Filer: from 3 before 3.3.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2024-11404?

3 open source packages ship an affected version, including django-filer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-filer` | PyPI | All versions | 3.3.0 |
| `django-filer` | PyPI | All versions | 3.3.0 |
| `django-filer` | PyPI | All versions | 3.3.0 |

## How do I fix CVE-2024-11404?

Upgrade django-filer to 3.3.0 or later.

## Is CVE-2024-11404 being exploited?

There is no known exploitation of CVE-2024-11404 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11404 and fix it if it is affected.

What it is: CVE-2024-11404 is a medium-severity vulnerability in django Filer, published on 20 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-11404 in the wild and no public exploit code.

Affected packages and fixed versions:
- django-filer (PyPI): affected all versions; fixed in 3.3.0
- django-filer (PyPI): affected all versions; fixed in 3.3.0
- django-filer (PyPI): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11404/ (Markdown: https://insights.sbomify.com/CVE-2024-11404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11404
- OSV: https://osv.dev/vulnerability/CVE-2024-11404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11404/
Summaries are generated and may contain mistakes; the official description above is the record.
