# CVE-2024-11406: Stored XSS in django CMS Attributes Fields

> Attackers can inject malicious scripts into django CMS Attributes Fields, potentially executing code in victim browsers.

- **Severity:** Medium 6.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Nov 2024
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-vxcv-4xvf-pc22, PYSEC-2026-1303

## What is CVE-2024-11406?

CVE-2024-11406 is a medium-severity cross-site scripting vulnerability in django CMS Attributes Fields, published on 20 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in django CMS Association django CMS Attributes Fields allows Stored XSS.

This issue affects django CMS Attributes Fields: before 4.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-11406?

3 open source packages ship an affected version, including djangocms-attributes-field.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `djangocms-attributes-field` | PyPI | All versions | 4.0.0 |
| `djangocms-attributes-field` | PyPI | All versions | 4.0.0 |
| `djangocms-attributes-field` | PyPI | All versions | 4.0.0 |

## How do I fix CVE-2024-11406?

Upgrade djangocms-attributes-field to 4.0.0 or later.

## Is CVE-2024-11406 being exploited?

There is no known exploitation of CVE-2024-11406 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11406 and fix it if it is affected.

What it is: CVE-2024-11406 is a medium-severity cross-site scripting vulnerability in django CMS Attributes Fields, published on 20 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-11406 in the wild and no public exploit code.

Affected packages and fixed versions:
- djangocms-attributes-field (PyPI): affected all versions; fixed in 4.0.0
- djangocms-attributes-field (PyPI): affected all versions; fixed in 4.0.0
- djangocms-attributes-field (PyPI): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11406/ (Markdown: https://insights.sbomify.com/CVE-2024-11406/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11406
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11406
- OSV: https://osv.dev/vulnerability/CVE-2024-11406

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11406/
Summaries are generated and may contain mistakes; the official description above is the record.
