# CVE-2024-1141: Glance-store: glance store access key logged in debug log level

> Attackers with log access can retrieve sensitive access keys if debug logging is enabled in the Glance Store library.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2024
- **Updated:** 20 Nov 2025
- **Also known as:** DEBIAN-CVE-2024-1141, GHSA-wgpq-p2hm-56v9, PYSEC-2026-1405, RHSA-2024:2732, UBUNTU-CVE-2024-1141, USN-6630-1

## What is CVE-2024-1141?

CVE-2024-1141 is a medium-severity vulnerability in Red Hat OpenStack Platform 16.1, published on 1 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in python-glance-store. The issue occurs when the package logs the access_key for the glance-store when the DEBUG log level is enabled.

Weakness: CWE-779 (Logging of Excessive Data)

## Which versions are affected by CVE-2024-1141?

3 open source packages ship an affected version, including glance-store. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glance-store` | PyPI | All versions to 4.6.1 | None |
| `glance-store` | PyPI | All versions to 4.6.1 | None |
| `glance-store` | PyPI | All versions | 4.7.0 |
| `python-glance-store` | Red Hat:openstack:17.1::el9 | All versions | 0:2.5.1-17.1.20230621023901.el9ost |
| `python3-glance-store` | Red Hat:openstack:17.1::el9 | All versions | 0:2.5.1-17.1.20230621023901.el9ost |

Products: Openstack Glance-Store.

## How do I fix CVE-2024-1141?

Upgrade glance-store to 4.7.0 or later.

## Is CVE-2024-1141 being exploited?

There is no known exploitation of CVE-2024-1141 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1141 and fix it if it is affected.

What it is: CVE-2024-1141 is a medium-severity vulnerability in Red Hat OpenStack Platform 16.1, published on 1 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-1141 in the wild and no public exploit code.

Affected packages and fixed versions:
- glance-store (PyPI): affected all versions up to 4.6.1; no fix listed
- glance-store (PyPI): affected all versions up to 4.6.1; no fix listed
- glance-store (PyPI): affected all versions; fixed in 4.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1141/ (Markdown: https://insights.sbomify.com/CVE-2024-1141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1141
- OSV: https://osv.dev/vulnerability/CVE-2024-1141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1141/
Summaries are generated and may contain mistakes; the official description above is the record.
