# CVE-2024-1143: Central Dogma Authentication Bypass Vulnerability via Session Leakage


- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 2 Feb 2024
- **Updated:** 3 Jun 2025
- **Also known as:** GHSA-34q3-p352-c7q8

## What is CVE-2024-1143?

CVE-2024-1143 is a critical vulnerability in LINE Corporation Central Dogma, published on 2 Feb 2024. 

### Official description

Central Dogma versions prior to 0.64.1 is vulnerable to Cross-Site Scripting (XSS), which could allow for the leakage of user sessions and subsequent authentication bypass.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-1143?

2 open source packages ship an affected version, including com.linecorp.centraldogma:centraldogma-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.linecorp.centraldogma:centraldogma-server` | Maven | All versions | 0.64.1 |
| `com.linecorp.centraldogma:centraldogma-server` | Maven | All versions | 0.64.1 |

Products: Linecorp Central Dogma.

## How do I fix CVE-2024-1143?

Upgrade com.linecorp.centraldogma:centraldogma-server to 0.64.1 or later.

## Is CVE-2024-1143 being exploited?

There is no known exploitation of CVE-2024-1143 in the wild and no public exploit code.

## Other vulnerabilities in LINE Corporation Central Dogma

- [CVE-2021-38388](https://insights.sbomify.com/CVE-2021-38388/): Privilege escalation in Central Dogma (high 8.8)
- [CVE-2025-11222](https://insights.sbomify.com/CVE-2025-11222/): Central Dogma's Login Function Has an Open Redirect Vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1143 and fix it if it is affected.

What it is: CVE-2024-1143 is a critical vulnerability in LINE Corporation Central Dogma, published on 2 Feb 2024. 
Exploitation: There is no known exploitation of CVE-2024-1143 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.linecorp.centraldogma:centraldogma-server (Maven): affected all versions; fixed in 0.64.1
- com.linecorp.centraldogma:centraldogma-server (Maven): affected all versions; fixed in 0.64.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1143/ (Markdown: https://insights.sbomify.com/CVE-2024-1143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1143
- OSV: https://osv.dev/vulnerability/CVE-2024-1143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1143/
Summaries are generated and may contain mistakes; the official description above is the record.
