{"answers":{"affected":"2 open source packages ship an affected version, including mapshaper. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1163 exists.","fix":"Upgrade mapshaper to 0.6.44 or later.","what":"CVE-2024-1163 is a high-severity path traversal vulnerability in mbloch/mapshaper, published on 13 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-1163 and fix it if it is affected.\n\nWhat it is: CVE-2024-1163 is a high-severity path traversal vulnerability in mbloch/mapshaper, published on 13 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1163 exists.\n\nAffected packages and fixed versions:\n- mapshaper (npm): affected all versions; fixed in 0.6.44\n- mapshaper (npm): affected all versions; fixed in 0.6.44\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-1163/ (Markdown: https://insights.sbomify.com/CVE-2024-1163/index.md)","id":"CVE-2024-1163","markdown":"https://insights.sbomify.com/CVE-2024-1163/index.md","name":"CVE-2024-1163","record":{"aliases":["GHSA-8m36-62rw-9mxw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"JavaScript mapping library","requires_auth":"none","summary":"An attacker can exploit a path traversal vulnerability in mapshaper to disclose sensitive information.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"mapshaper","vendor":"mapshaper"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"The attacker may exploit a path traversal vulnerability leading to information disclosure.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Path traversal vulnerability in mapshaper","id":"CVE-2024-1163","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Brizy – Page Builder \u003c= 2.4.43 - Authenticated(Contributor+) Stored Cross-Site Scripting via Form Functionality","id":"CVE-2024-1164"},"packages":[{"ecosystem":"npm","fixed":["0.6.44"],"introduced":["0"],"last_affected":[],"package":"mapshaper","purl":null,"source":"GHSA-8m36-62rw-9mxw"},{"ecosystem":"npm","fixed":["0.6.44"],"introduced":["0"],"last_affected":[],"package":"mapshaper","purl":"pkg:npm/mapshaper","source":"GHSA-8m36-62rw-9mxw"}],"prev":{"headline":"Orbit Fox by ThemeIsle \u003c= 2.10.29 - Cross-Site Request Forgery","id":"CVE-2024-1162"},"products":["mbloch/mapshaper"],"published":"2024-02-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-09","vendors":["mbloch"]},"summary":"An attacker can exploit a path traversal vulnerability in mapshaper to disclose sensitive information.","url":"https://insights.sbomify.com/CVE-2024-1163/"}