# CVE-2024-1163: Path traversal vulnerability in mapshaper

> An attacker can exploit a path traversal vulnerability in mapshaper to disclose sensitive information.

- **Severity:** High 7.7 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Feb 2024
- **Updated:** 9 May 2025
- **Also known as:** GHSA-8m36-62rw-9mxw

## What is CVE-2024-1163?

CVE-2024-1163 is a high-severity path traversal vulnerability in mbloch/mapshaper, published on 13 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The attacker may exploit a path traversal vulnerability leading to information disclosure.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-1163?

2 open source packages ship an affected version, including mapshaper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mapshaper` | npm | All versions | 0.6.44 |
| `mapshaper` | npm | All versions | 0.6.44 |

Products: Mapshaper Mapshaper.

## How do I fix CVE-2024-1163?

Upgrade mapshaper to 0.6.44 or later.

## Is CVE-2024-1163 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1163 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1163 and fix it if it is affected.

What it is: CVE-2024-1163 is a high-severity path traversal vulnerability in mbloch/mapshaper, published on 13 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-1163 exists.

Affected packages and fixed versions:
- mapshaper (npm): affected all versions; fixed in 0.6.44
- mapshaper (npm): affected all versions; fixed in 0.6.44

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1163/ (Markdown: https://insights.sbomify.com/CVE-2024-1163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1163
- OSV: https://osv.dev/vulnerability/CVE-2024-1163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1163/
Summaries are generated and may contain mistakes; the official description above is the record.
