# CVE-2024-1165: Brizy – Page Builder <= 2.4.39 - Authenticated (Contributor+) Directory Traversal

> Authenticated contributors can exploit a directory traversal flaw to upload files to arbitrary server locations, potentially leading to code execution.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Feb 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-89r2-jh3p-h38p

## What is CVE-2024-1165?

CVE-2024-1165 is a medium-severity path traversal vulnerability in themefusecom Brizy – Page Builder, published on 24 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Brizy – Page Builder plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 2.4.39 via the 'id'. This makes it possible for authenticated attackers, with contributor-level access and above, to upload files to arbitrary locations on the server

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-1165?

It affects 1 product.


Products: Brizy Brizy.

## How do I fix CVE-2024-1165?

No fix has been published for CVE-2024-1165 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-1165 being exploited?

There is no known exploitation of CVE-2024-1165 in the wild and no public exploit code.

## Other vulnerabilities in themefusecom Brizy – Page Builder

- [CVE-2024-10960](https://insights.sbomify.com/CVE-2024-10960/): Brizy – Page Builder <= 2.6.4 - Authenticated (Contributor+) Arbitrary File Upload via storeUploads (critical 9.9)
- [CVE-2024-3242](https://insights.sbomify.com/CVE-2024-3242/): Brizy – Page Builder <= 2.4.44 - Authenticated (Contributor+) Arbitrary File Upload (high 8.8)
- [CVE-2024-1311](https://insights.sbomify.com/CVE-2024-1311/): Brizy – Page Builder <= 2.4.40 - Authenticated (Contributor+) Arbitrary File Upload (high 8.8)
- [CVE-2024-3667](https://insights.sbomify.com/CVE-2024-3667/): Brizy – Page Builder <= 2.4.43 - Authenticated (Contributor+) Store Cross-Site Scripting via Widget Link To URL (high 7.4)
- [CVE-2020-36714](https://insights.sbomify.com/CVE-2020-36714/): Brizy < 1.0.126 - Authorization Bypass to Settings Updates (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-1165 and fix it if it is affected.

What it is: CVE-2024-1165 is a medium-severity path traversal vulnerability in themefusecom Brizy – Page Builder, published on 24 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-1165 in the wild and no public exploit code.

Affected product: themefusecom Brizy – Page Builder. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-1165/ (Markdown: https://insights.sbomify.com/CVE-2024-1165/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-1165
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-1165
- OSV: https://osv.dev/vulnerability/CVE-2024-1165

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-1165/
Summaries are generated and may contain mistakes; the official description above is the record.
