CVE-2024-11668 Insufficient Session Expiration in GitLab

Medium 4.2 Published Updated

Attackers can bypass authentication via long-lived connections to access streaming results, requiring GitLab administrators to upgrade.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-11668?

CVE-2024-11668 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 26 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 16.11 before 17.4.5, 17.5 before 17.5.3, and 17.6 before 17.6.1. Long-lived connections could potentially bypass authentication controls, allowing unauthorized access to streaming results.

Weakness: CWE-613

Which versions are affected by CVE-2024-11668?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.11.017.4.5, 17.5.3, 17.6.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-11668?

Upgrade gitlab to a fixed version for your release line: 17.4.5, 17.5.3 or 17.6.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-11668 being exploited?

There is no known exploitation of CVE-2024-11668 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-11668, GHSA-g797-r4r7-wp94, UBUNTU-CVE-2024-11668.

Is CVE-2024-11668 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free