CVE-2024-11669 Incorrect Authorization in GitLab

Medium 6.5 Published Updated

Attackers can access sensitive data via API endpoints due to overly broad token scopes in GitLab.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-11669?

CVE-2024-11669 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 26 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue was discovered in GitLab CE/EE affecting all versions from 16.9.8 before 17.4.5, 17.5 before 17.5.3, and 17.6 before 17.6.1. Certain API endpoints could potentially allow unauthorized access to sensitive data due to overly broad application of token scopes.

Weakness: CWE-863

Which versions are affected by CVE-2024-11669?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.9.817.4.5, 17.5.3, 17.6.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-11669?

Upgrade gitlab to a fixed version for your release line: 17.4.5, 17.5.3 or 17.6.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-11669 being exploited?

There is no known exploitation of CVE-2024-11669 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-11669, GHSA-v84c-53c6-xmmp, UBUNTU-CVE-2024-11669.

Is CVE-2024-11669 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free