# CVE-2024-11718: tarteaucitron.js for WordPress < 0.3.0 - Author+ Stored XSS

> Author-level users can inject malicious HTML into posts, enabling stored cross-site scripting attacks against other users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 May 2025
- **Updated:** 20 May 2025
- **Also known as:** GHSA-fxpc-qmrh-7j2h

## What is CVE-2024-11718?

CVE-2024-11718 is a medium-severity cross-site scripting vulnerability in Unknown tarteaucitron-wp, published on 15 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The tarteaucitron-wp WordPress plugin before 0.3.0 allows author level and above users to add HTML into a post/page, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-11718?

2 open source packages ship an affected version, including couleurcitron/tarteaucitron-wp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `couleurcitron/tarteaucitron-wp` | Packagist | All versions | 0.3.0 |
| `couleurcitron/tarteaucitron-wp` | Packagist | All versions | 0.3.0 |

Products: Couleurcitron Tarteaucitron-Wp.

## How do I fix CVE-2024-11718?

Upgrade couleurcitron/tarteaucitron-wp to 0.3.0 or later.

## Is CVE-2024-11718 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11718 exists.

## Other vulnerabilities in Unknown tarteaucitron-wp

- [CVE-2024-11719](https://insights.sbomify.com/CVE-2024-11719/): tarteaucitron.js for WordPress < 0.3.0 - Stored XSS via CSRF (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11718 and fix it if it is affected.

What it is: CVE-2024-11718 is a medium-severity cross-site scripting vulnerability in Unknown tarteaucitron-wp, published on 15 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-11718 exists.

Affected packages and fixed versions:
- couleurcitron/tarteaucitron-wp (Packagist): affected all versions; fixed in 0.3.0
- couleurcitron/tarteaucitron-wp (Packagist): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11718/ (Markdown: https://insights.sbomify.com/CVE-2024-11718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11718
- OSV: https://osv.dev/vulnerability/CVE-2024-11718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11718/
Summaries are generated and may contain mistakes; the official description above is the record.
