# CVE-2024-11734: Org.keycloak:keycloak-quarkus-server: denial of service in keycloak server via security headers

> An administrative user can cause a denial of service in Keycloak by inserting newlines into security headers, disrupting server request handling.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2025
- **Updated:** 31 Aug 2026
- **Also known as:** ECHO-2aab-293d-53af, GHSA-w3g8-r9gw-qrh8

## What is CVE-2024-11734?

CVE-2024-11734 is a medium-severity denial of service vulnerability in Red Hat RHBK 26.0.8, published on 14 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A denial of service vulnerability was found in Keycloak that could allow an administrative user with the right to change realm settings to disrupt the service. This action is done by modifying any of the security headers and inserting newlines, which causes the Keycloak server to write to a request that has already been terminated, leading to the failure of said request.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2024-11734?

2 open source packages ship an affected version, including org.keycloak:keycloak-quarkus-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-quarkus-server` | Maven | All versions | 26.0.8 |
| `org.keycloak:keycloak-quarkus-server` | Maven | All versions | 26.0.8 |

## How do I fix CVE-2024-11734?

Upgrade org.keycloak:keycloak-quarkus-server to 26.0.8 or later.

## Is CVE-2024-11734 being exploited?

There is no known exploitation of CVE-2024-11734 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11734 and fix it if it is affected.

What it is: CVE-2024-11734 is a medium-severity denial of service vulnerability in Red Hat RHBK 26.0.8, published on 14 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-11734 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-quarkus-server (Maven): affected all versions; fixed in 26.0.8
- org.keycloak:keycloak-quarkus-server (Maven): affected all versions; fixed in 26.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11734/ (Markdown: https://insights.sbomify.com/CVE-2024-11734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11734
- OSV: https://osv.dev/vulnerability/CVE-2024-11734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11734/
Summaries are generated and may contain mistakes; the official description above is the record.
