# CVE-2024-11736: Org.keycloak:keycloak-quarkus-server: unrestricted admin use of system and environment variables

> Admin users can access sensitive server environment variables and system properties via placeholder injection in configurable URLs.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2025
- **Updated:** 31 Aug 2026
- **Also known as:** ECHO-9e12-01fd-007b, GHSA-f4v7-3mww-9gc2

## What is CVE-2024-11736?

CVE-2024-11736 is a medium-severity vulnerability in Red Hat RHBK 26.0.8, published on 14 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A vulnerability was found in Keycloak. Admin users may have to access sensitive server environment variables and system properties through user-configurable URLs. When configuring backchannel logout URLs or admin URLs, admin users can include placeholders like ${env.VARNAME} or ${PROPNAME}. The server replaces these placeholders with the actual values of environment variables or system properties during URL processing.

Weakness: CWE-526 (Cleartext Storage of Sensitive Information in an Environment Variable)

## Which versions are affected by CVE-2024-11736?

2 open source packages ship an affected version, including org.keycloak:keycloak-quarkus-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-quarkus-server` | Maven | All versions | 26.0.8 |
| `org.keycloak:keycloak-quarkus-server` | Maven | All versions | 26.0.8 |

## How do I fix CVE-2024-11736?

Upgrade org.keycloak:keycloak-quarkus-server to 26.0.8 or later.

## Is CVE-2024-11736 being exploited?

There is no known exploitation of CVE-2024-11736 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-11736 and fix it if it is affected.

What it is: CVE-2024-11736 is a medium-severity vulnerability in Red Hat RHBK 26.0.8, published on 14 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-11736 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-quarkus-server (Maven): affected all versions; fixed in 26.0.8
- org.keycloak:keycloak-quarkus-server (Maven): affected all versions; fixed in 26.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-11736/ (Markdown: https://insights.sbomify.com/CVE-2024-11736/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-11736
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-11736
- OSV: https://osv.dev/vulnerability/CVE-2024-11736

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-11736/
Summaries are generated and may contain mistakes; the official description above is the record.
